Come copiare e incollare un elenco in ordine inverso – Excel Espresso

Stampa l'articolo

Sapete come copiare e incollare un elenco di dati o nominativi ma in ordine inverso? 

Qui troverete 3 metodi per invertire l’ordine di un elenco.

Partiremo dal metodo un po’ più complicato con il quale sfrutteremo l’uso delle funzioni CONTA.VALORI e INDICE.

Questo è il link dove potrete approfondire la funzione INDICE.

Prima prepariamo i fogli di lavoro, aggiungiamo 3 nuovi fogli, copiamo i valori che ci interessano, dalla cella A2 alla cella A10, pulsante destro del mouse, copia, spostiamoci sul foglio2 ora tenendo premuto il tasto CTRL selezioniamo tutti e tre i fogli, questo è un piccolo trucco per far si che tutte le operazioni che andremo fare sul foglio2 verranno replicate anche sul foglio3 e foglio4.

Torniamo sul foglio2, portiamoci nella cella B2 e scriviamo la funzione:

=CONTA.VALORI(A2:A10)

Prima di dare invio ci portiamo sul riferimento A10 e premiamo il tasto F4 per dare alla posizione A10 un riferimento assoluto,.

= CONTA.VALORI(A2:$A$10)

Diamo invio e trasciniamo fino in basso copiando la funzione nelle celle sottostanti.

Come forse avrete intuito questo ci indicherà il nuovo ordinamento.

Portiamoci nella cella C2 e sfruttando la funzione INDICE scriviamo:

=INDICE($A$2:$A$10

La matrice corrisponderà all’intervallo A2:A10, ricordiamoci di rendere assoluti i riferimenti premendo il tasto F4

mentre per l’argomento riga non dovremo far altro che riscrivere la funzione CONTA.VALORI che abbiamo visto pochi istanti fa

=INDICE($A$2:$A$10;CONTA.VALORI(A2:$A$10))

Diamo invio ed anche in questo caso trasciniamo verso il basso copiando la funzione nelle celle sottostanti.

Il contenuto della colonna B ora possiamo anche cancellarlo, e come potete vedere il risultato è quello di avere creato un ordinamento inverso rispetto all’elenco di partenza.

Passiamo ora al secondo metodo nel quale useremo l’ordinamento dei dati presente in Excel

Portiamoci nel foglio3, nella cella B2 digitiamo il n° 1, nella cella B3 scriviamo 2, selezioniamo queste 2 celle e trasciniamo verso il basso, Excel completerà in modo automatico la sequenza

Ora copiamo il contenuto delle celle A2:A10 nella cella C2, quindi CTRL+C  CTRL+V

Selezioniamo l’intervallo B2:C10, portiamoci nella scheda Dati e scegliamo Ordina

Si aprirà la finestra di ordinamento nella quale sceglieremo:

Ordina per Colonna B e come ordine Dal più grande al più piccolo

Diamo OK, cancelliamo il contenuto della colonna B, ed abbiamo ottenuto lo stesso risultato visto con il primo metodo.

Infine, passiamo al terzo metodo nel quale useremo l’ordinamento sfruttando i filtri di Excel

Portiamoci nel foglio4, anche in questo caso dovremo creare la sequenza fatta in precedenza, nella cella B2 digitiamo il n° 1, nella cella B3 scriviamo 2, selezioniamo queste 2 celle e trasciniamo verso il basso.

Copiamo il contenuto delle celle A2:A10 nella cella C2, quindi CTRL+C  CTRL+V

Selezioniamo l’intervallo B1:C10 e questo punto usiamo la combinazione di tasti CTRL+MAIUSC+L

Nel filtro posizionato sulla cella B2 scegliamo Ordina dal più grande al più piccolo

Anche in questo caso possiamo eliminare il contenuto della colonna B e ripremendo la combinazione di tasti CTRL+MAIUSC+L elimineremo il filtro ottenendo il risultato visto con i precedenti metodi.

Per oggi è tutto e spero che quanto visto possa tornarvi utile.

Scrivetemi nei commenti quale dei tre metodi visti preferite.

Nel video qui sotto trovate tutti i passaggi appena illustrati, buona visione.

Condividi il post

Facebook
Twitter
LinkedIn
Email
WhatsApp

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Articoli correlati

Tips & Tricks

Trovare l’ultimo valore in colonna

Volete trovare l’ultimo valore presente in una colonna? Se a priori non sapete quante celle popolano la colonna o volete un metodo dinamico per conoscere l’ultimo valore, seguite questi passaggi.

Read More »
Torna su