8 Errori in Excel, come riconoscerli e correggerli

Lavorando con Excel può capitare di digitare male una formula, scrivere un testo al posto di un numero o dare un riferimento errato ad una funzione, queste sono solo alcune delle cause di errori più frequenti in Excel, le quali danno come risultato la generazione di un codice d’errore.

Inziamo con l’Errore n° 1#NUM!

L’errore #NUM! Si presenta quando in una formula o una funzione contiene dei valori numerici che non sono validi oppure con dei valori che superano il limite di calcolo di Excel.

Se volessimo estrarre la radice quadrata dei numeri indicati nella colonna A useremo la funzione =RADQ(A)

Trasciniamo la funzione nelle celle sottostanti, con valori positivi avremo il relativo risultato, mentre i valori negativi genereranno l’errore #NUM!

Lo stesso tipo di errore sarà restituito nel caso in cui superassimo i limiti di calcolo di Excel, per fare questo usiamo l’elevamento a potenza che in Excel si fa usando il simbolo che trovate sopra la i accentata che ha la forma dell’accento circonflesso.

=10^2

Il limite massimo è fissato a =10^308 per intenderci stiamo parlando di un numero composto da 308 zeri

Se infatti proviamo ad indicare =10^309 comparirà l’errore #NUM!

Errore n° 2#VALORE!

L’errore #VALORE! Si presenta quando i tipi di dato dei riferimenti di una formula non corrispondono, potremmo incontrarlo quando vogliamo sommare o sottrarre dei valori, ma all’interno di una c’è del testo

Nella cella C2 scriviamo =A2+B2 e trasciniamo sotto, la cella B3 non comporta alcun problema perché è vuota, ma poiché nella cella B4 c’è del testo la formula restituirà l’errore #VALORE!

La soluzione a questo problema potrebbe essere quella di ricontrollare i valori che abbiamo inserito ed assicurarci che ci siano solo valori numerici, oppure potremmo raggirare l’ostacolo utilizzando la funzione SOMMA

Infatti se nella cella C5 scriviamo =SOMMA(A5:B5), non verrà visualizzato alcun errore.

Errore n° 3#RIF!

Abbiamo l’errore #RIF! Quando manca un riferimento ad una cella oppure il riferimento che si tenta di dare è errato, il motivo più comune potrebbe essere perché abbiamo eliminato righe o colonne che erano coinvolte nel calcolo

Un altro motivo potrebbe essere che abbiamo copiamo una formula i cui riferimenti sono errati, se copiassimo la formula della cella C2, nella cella A7 anche in questo caso otterremmo l’errore #RIF!

Errore n° 4#NOME?

L’errore #NOME? Lo riscontriamo quando si inserisce il nome errato o inesistente di una funzione.

Per evitare errori di questo tipo possiamo aiutarci con l’elenco che compare quando digitiamo una funzione nella barra delle formule.

Errore n° 5#DIV/0!  

Quando dividiamo un valore per 0, oppure il riferimento del divisore è una cella vuota, otteniamo l’errore #DIV/0!

Nella cella C2 scriviamo:

=A2/B2 e trasciniamo nelle celle sottostanti

Possiamo evitare l’errore con le funzioni SE oppure SE.ERRORE

Nella cella C4 scriviamo:

=SE(B4=0;”-“;A4/B4)

Per usare la funzione SE.ERRORE nella cella C5 scriviamo:

=SE.ERRORE(A5/B5;”-“)

Errore n° 6 #NULL!  

Probabilmente questo è un errore meno conosciuto, l’errore #NULL!  si verifica quando viene indicato un intervallo senza il separatore corretto, quindi potrebbe essere la mancanza del “;” per separare due intervalli diversi, oppure i “:” per indicare un intervallo di celle.

Se volessimo effettuare la somma dei valori contenuti nell’intervallo A2:A5 e per errore nella cella A6 scrivessimo:

=SOMMA(A2 A5)

Si manifesterà l’errore #NULL!, per correggerlo basterà mettere il simbolo dei “:” tra A2 e A5

Errore n° 7 #N/D!  

Questo codice d’errore è tipico delle funzioni che permettono di cercare valori all’interno di un intervallo, per esempio quando usiamo una funzione di ricerca come CERCA.VERT.

Scriviamo la funzione nella cella D2

=CERCA.VERT(“GIALLO”;A2:B6;2)

Per evitare che compaia questo errore possiamo usare le funzioni SE.NON.DISP. oppure SE.ERRORE

=SE.NON.DISP.(CERCA.VERT(“GIALLO”;A2:B6;2);”-“)

Se preferiamo l’utilizzo della funzione SE.ERRORE la sintassi è identica, ci basterà cambiare da SE.NON.DISP  a SE.ERRORE

=SE.ERRORE(CERCA.VERT(“GIALLO”;A2:B6;2);”-“)

Errore n°8 ### (serie di cancelletti)  

In realtà quando vediamo una serie di cancelletti, non si tratta di un vero e proprio errore ma è una segnalazione che la larghezza assegnata alla cella non è sufficiente per visualizzare il risultato, infatti ci basterà aumentare la larghezza della colonna per far comparire il contenuto delle celle.

Nel video qui sotto trovate tutti i passaggi appena illustrati, buona visione.

Condividi il post

Facebook
Twitter
LinkedIn
Email
WhatsApp

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Articoli correlati

Tips & Tricks

La formattazione condizionale – (parte5)

La Formattazione condizionale ci permette di mettere in risalto singole celle, righe o colonne applicando diversi formati e stili al foglio ogni qualvolta che i dati presenti soddisfano una o più condizioni. Vedremo come usare la formattazione condizionale abbinandola alle caselle di controllo.

Read More »
Torna su