La funzione MODA

Stampa l'articolo

Nella vasta gamma di funzioni statistiche che Excel ci offre, oggi vedremo la funzione MODA la quale ci permette di cercare il valore più ricorrente all’interno di un elenco numerico, vedremo anche come sfruttare questa funzione in combinazione ad altre, per cercare sempre il valore più ricorrente ma in un elenco in formato testo.

Partiamo subito col dire quali sono gli argomenti che compongono questa funzione:

Num1, Num2 e via dicendo rappresentano i riferimenti, gli intervalli o le matrici di cui si desidera calcolare la MODA

Se un riferimento contiene del testo, valori logici o celle vuote, tali valori verranno ignorati, mentre le celle che contengono il valore zero saranno incluse nel calcolo.

Se l’insieme dei dati contiene valori unici, la funzione MODA non sarà in grado di trovare il valore più ricorrente e restituirà l’errore #N/D.

Qui trovate il link dedicato agli errori di Excel,   ed il relativo video.

Nella tabella in questione troviamo i nomi di alcuni studenti e nella colonna E la relativa altezza, il nostro intento è quello di scovare l’altezza più frequente. Sarà sufficiente portarsi nella cella G3 e scrivere:

=MODA(E2:E23)

Per evidenziare dove si trovano i valori più frequenti possiamo aiutarci con la formattazione condizionale.

Selezioniamo le celle E2:E23, portiamoci in formattazione condizionale, Regole evidenziazione celle, quindi Uguale a

e da qui, Formatta celle con valore uguale a ed indichiamo la cella G3 dove è contenuto il risultato della funzione MODA e diamo ok.

Come detto in partenza, MODA lavora con dati in formato numerico, quindi se volessimo trovare qual è il nome più frequente dovremo associare altre due funzioni, INDICE e CONFRONTA.

Portiamoci nella cella H3 e scriviamo:

=INDICE($A$2:$C$10;CONFRONTA(A12;$D$2:$D$10;0);1)

Anche in questo caso sfruttiamo la formattazione condizionale per evidenziare il nome che compare con maggior frequenza. Selezioniamo le celle A2:A23, portiamoci in formattazione condizionale, Regole evidenziazione celle, quindi Uguale a

e da qui, Formatta celle con valore uguale a ed indichiamo la cella H3 e diamo ok.

Dopo aver trovato l’altezza ed il nome con maggiore ricorrenza, potremmo scoprire quante volte si presentano questi valori all’interno dell’elenco, per fare ciò ci basterà usare la funzione CONTA.SE.

Nella cella G5 scriviamo:

=CONTA.SE(E2:E23;G3)

Il risultato è 6 che corrisponde ai valori evidenziati con la formattazione condizionale.

Per i nomi faremo la stessa procedura, quindi nella cella H5 scriviamo:

=CONTA.SE(A2:A23;H3)

Il risultato pari a 5 corrisponde ai valori evidenziati dalla formattazione condizionale.

Nel video qui sotto trovate tutti i passaggi appena illustrati, buona visione.

Condividi il post

Facebook
Twitter
LinkedIn
Email
WhatsApp

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Articoli correlati

Tips & Tricks

Trovare l’ultimo valore in colonna

Volete trovare l’ultimo valore presente in una colonna? Se a priori non sapete quante celle popolano la colonna o volete un metodo dinamico per conoscere l’ultimo valore, seguite questi passaggi.

Read More »
Torna su