La funzione MEDIA.PIÙ.SE

La funzione MEDIA.PIÙ.SE ci permette di calcolare la media di valori o di intervalli che soddisfano più criteri.

Gli argomenti della funzione MEDIA.PIÙ.SE sono i seguenti:

  • int_media è l’intervallo di celle da calcolare, i cui valori soddisferanno i vari criteri
  • int_criteri1, int_criteri2… sono gli intervalli di celle a cui applicare i criteri
  • criterio1, criterio2…sono i criteri che noi impostiamo

La funzione MEDIA.PIÙ.SE esegue la media quando un determinato intervallo soddisfa più di un criterio, grazie al nostro elenco vogliamo trovare il costo medio di una camera in base al numero di stelle per ogni regione.

Portiamoci nella cella H17 e scriviamo la funzione:

=MEDIA.PIÙ.SE(D:D;B:B;G17;C:C;H16)

Per estendere il risultato anche nelle altre celle dovrò dare dei riferimenti assoluti all’intervallo media e agli intervalli criteri in modo tale che questi non cambino durante la fase di trascinamento.

Modifichiamo la funzione contenuta nella cella H17 in questo modo:

=MEDIA.PIÙ.SE($D:$D;$B:$B;$G17;$C:$C;H$16)

e trasciniamo col pulsante sinistro del mouse il contenuto della cella H17 anche nelle celle a fianco.

Dopo aver completato la prima riga sempre col pulsante sinistro del mouse trasciniamo per riempire anche le celle sottostanti.

Excel ci ha restituito il risultato della media del costo della camera tuttavia come vedete, abbiamo ottenuto anche degli errori. In Excel viene visualizzato l’errore #DIV/0! quando il numero viene diviso per 0, nel nostro caso specifico significa che la ricerca non ha dato alcun risultato. Cosa fare per correggere questo errore? Potremmo nidificare la funzione SE.ERRORE modificando la funzione in questo modo, portiamoci nella cella H17 e scriviamo:

=SE.ERRORE(MEDIA.PIÙ.SE($D:$D;$B:$B;$G17;$C:$C;H$16);0)

Completiamo il tutto ripetendo le operazioni di trascinamento, nelle celle che prima contenevano l’errore ora non verrà visualizzato alcun valore.

Se si desidera calcolare la media dei valori che soddisfano un singolo criterio, possiamo utilizzare la funzione MEDIA.SE.

Mentre per calcolare la media di un determinato intervallo possiamo usare la funzione MEDIA.

Nel video qui sotto trovate tutti i passaggi appena illustrati ed altre informazioni utili, buona visione.

Condividi il post

Facebook
Twitter
LinkedIn
Email
WhatsApp

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Articoli correlati

Tips & Tricks

La formattazione condizionale – (parte5)

La Formattazione condizionale ci permette di mettere in risalto singole celle, righe o colonne applicando diversi formati e stili al foglio ogni qualvolta che i dati presenti soddisfano una o più condizioni. Vedremo come usare la formattazione condizionale abbinandola alle caselle di controllo.

Read More »
Torna su