La funzione CONTA.SE

Stampa l'articolo

Nell’intervallo A2:A9 ho inserito 8 valori che sono rispettivamente: un numero, una percentuale che è assimilabile ad un valore numerico, una cella vuota, testo, numeri e testo che Excel interpreta essere come un normalissimo testo, una formula che da un risultato numerico, una data che è sempre interpretata come un valore numerico, ed infine una funzione che può cambiare il proprio risultato da numerico oppure testo.

gli argomenti della funzione CONTA.SE sono:

Intervallo rappresenta proprio l’intervallo in cui si desidera effettuare la ricerca.

Criterio rappresenta la condizione affinchè i valori vengano conteggiati.

Se volessimo contare le celle vuote nell’intervallo A2:A9, nella cella C5 scriveremo la funzione in questo modo:

=CONTA.SE(A2:A9;””) 

in questo caso è come se replicassimo la funzione: CONTA.VUOTE

Ora vediamo come scrivere la funzione CONTA.SE in modo che conteggi solamente le celle non vuote, in sostanza andremo a replicare la funzione CONTA.VALORI, in C6 scriviamo:

=CONTA.SE(A2:A9;”<>”)

Ora andiamo ad affinare un po’ la nostra ricerca, se volessimo trovare le celle che contengono solo un testo composto da 2 lettere dovremo sfruttare il carattere jolly: punto interrogativo.

Nella cella C7 scriviamo quindi:

=CONTA.SE(A2:A9;”??”)

Il risultato pari a 1 è dovuto dal fatto che l’unica cella che contiene un testo di 2 lettere è la cella A5

Andiamo ancora più nello specifico, ora vogliamo trovare solo quelle celle che contengono testo, quindi escludendo sia le celle vuote, sia le celle che contengono numeri, portiamoci nella cella C8 e scriviamo la funzione in questo modo:

=CONTA.SE(A2:A9;”*”)

Le uniche 2 celle che contengo testo sono la A5 e la A6, giustificando il risultato pari a 2

Infine facciamo l’operazione inversa a quella appena vista, cioè andiamo a contare tutte quelle celle che non contengono testo ovvero che siano vuote oppure che abbiano al loro interno dei numeri, nella cella C9 andiamo a scrivere:

=CONTA.SE(A2:A9;”<>*”)

Essendo le celle totali 8 e quelle che contengono testo solamente 2, il risultato non potrà che essere 6

Per concludere, nel caso in cui modificassimo la funzione nella cella A9, facendo in modo che il risultato non fosse più numerico ma testo, cambieranno conseguentemente anche i risultati delle varie funzioni.

Potrebbe interessarti anche:

La funzione CONTA.NUMERI

La funzione CONTA.VUOTE

La funzione CONTA.VALORI

Nel video qui sotto trovate tutti i passaggi appena illustrati, buona visione.

Ti consiglio di guardare anche il video dedicato alle funzioni

CONTA.VALORI, CONTA.NUMERI, CONTA.VUOTE

Condividi il post

Facebook
Twitter
LinkedIn
Email
WhatsApp

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Articoli correlati

Tips & Tricks

Trovare l’ultimo valore in colonna

Volete trovare l’ultimo valore presente in una colonna? Se a priori non sapete quante celle popolano la colonna o volete un metodo dinamico per conoscere l’ultimo valore, seguite questi passaggi.

Read More »
Torna su